css hack 适配IE5.0、IE5.5、IE6.0、IE7.0、FF1.5、FF2.0 访

日期:2021-03-12 类型:科技新闻 

关键词:微信小程序商城,免费微信小程序,小程序设计软件,小程序生成平台,可查询的小程序

IE7.0简体汉语宣布版公布了,针对我等常和网页页面打交道的人来讲网页页面适配性难题也随之而来了。IE7.0有1个明显的更改便是适用!important了,是件好事儿情,可是也给众多的在IE6时期应用!important来区别解决IE和FF的网页页面制做者带来了很多难题,Noker也碰到了这个难题,因此翻阅在网上材料,写了下面这个可以适配现如今大多数数流行访问器,遮盖绝大部分客户的Hack编码!

  适配访问器版本号:IE5.0,IE5.5,IE6.0,IE7.0,Firefox1.5,FireFox2.0

  CSS编码:(请重视Hack编码的次序)

拷贝编码
编码以下:

#test{
width:300px;
height:100px;
background:#DDD!important;/*FF*/
background:#FF0;/*IE5.0*/
}
#test/*IE5.5 */{
* background:#C0F!important;/*IE7.0*/
*background:#F00;/*IE6.0*/
*background /*IE5.5*/:#F90;
}


各访问器下的检测截图以下: